June 20, 2003
Microsoft Word Document

CONTENTS

1 Requirements
1.1 Software Requirement
1.2 Hardware Requirement

2 Functionality
2.1 Main Window
2.2 Menus
   2.2.1 File Menu
   2.2.2 Startup Menu
   2.2.3 Output Menu
   2.2.4 Windows Menu
   2.2.5 Help Menu
2.3 Sub Windows
   2.3.1 Sabre Display Window
   2.3.2 MDR Display Window
   2.3.3 SDS Display Window
   2.3.4 Timer Functions Window
   2.3.5 Hex Display Window
   2.3.6 XML Display Window
2.4 Select SDS Directory
2.5 Set up SABRE Communication
2.6 Connection to SABRE
2.7 Sign in/out SABRE
2.8 Send SABRE Command
2.9 Send SDS Command
   2.9.1 Send SDS Inbound Command
2.10 Retrieve MDR from SABRE Host
2.11 Retrieve/Save SABRE Transaction
2.12 Set up Printer Options
2.13 Set up Screen Options
2.14 File Test
2.15 Print Output
2.16 Export Output
2.17 Download Files from SDS Web Site
1 Requirements

1.1 Software Requirement

Win95/Win98/WinNT(Ver4.0)/Win2000 operating system should have been installed on the machine.

1.2 Hardware Requirement

The machine should have at least 32MB memory.
2 Functionality

The SDS test tool is an application that helps developers to test on SDS formatted messages retrieved from the SABRE host. The following sections contain the main functionality of the application.

2.1 Main Window

Double Clicking on Sds.exe file to pop up the main window of the SDS test tool as shown in Figure 1. Main Window.

![Figure 1. Main Window](image)

2.2 Menus
The main window has a menu bar that has five menu items: File, Startup, Output, Windows and Help. The following sub sections describe these menu items.

### 2.2.1 File Menu

![Figure 2. File Menu](image)

The File menu has seven submenus as shown in Figure 2. File Menu.

- **SDS Directory** - The usage of the submenu is described in Section 2.4 Select SDS Directory.
- **SABRE Communication** - The usage of the submenu is described in Section 2.5 Set up SABRE Communication.
- **SABRE Messages** - The usage of the submenu is described in Section 2.11 Retrieve/Save SABRE Transaction.
- **Printer Options** - The usage of the submenu is described in Section 2.12 Set up Printer Options.
- **Screen Options** - The usage of the submenu is described in Section 2.13 Set up Screen Options.
- **File Test** - The usage of the submenu is described in Section 2.14 File Test.
- **Clear MDRDB files** - Cears files used for decoding message.
- **Exit** - The submenu is used to exit the SDS test tool.
2.2.2 Startup Menu

The Startup menu has four submenus as shown in Figure 3 Startup Menu.

- **Connect** - The usage of the submenu is described in Section 2.6 Connection to Sabre.
- **Disconnect** - The usage of the submenu is described in Section 2.6 Connection to Sabre.
- **Sign in** - The usage of the submenu is described in Section 2.7 Sign in/out SABRE.
- **Sign out** - The usage of the submenu is described in Section 2.7 Sign in/out SABRE.

2.2.3 Output Menu

The Output menu has four submenus as shown in Figure 4. Output Menu.

- **Print from Active Screen** - The usage of the submenu is described in Section 2.15 Print Output.
- **Accumulate Print Yes/No** - Determines if Active Screen prints are accumulated or one per page.
- **Copy to Word** - The usage of the submenu is described in Section 2.16 Export Output.
- **Export SDS Output** - The usage of the submenu is described in Section 2.16 Export Output.
2.2.4 Windows Menu

The Windows menu has six fixed submenus as shown in Figure 5. Windows Menu.

- **Cascade** - The submenu is used to cascade opened sub windows in the main window.
- **Tile Horizontal** - The submenu is used to tile opened sub windows horizontally in the main window.
- **Tile Vertical** - The submenu is used to tile opened sub windows vertically in the main window.
- **Show All** - The submenu is used to display major sub windows.
- **Hide All** - The submenu is used to close all sub windows.
- **Open Window** - The submenu is used to open one of the sub windows.

The names of opened sub windows are listed as submenus after the second menu separator with check mark beside the active window.

2.2.5 Help Menu

The Help menu has six submenus as shown in Figure 6. Help Menu.

- **SDS Web Site** - The submenu is used to bring up your web browser to browse the SDS web site.
- **Download Description Database** - The usage of the submenu is described in Section 2.17 Download Files from SDS Web Site.
• **Download Program Install** - The usage of the submenu is described in Section 2.17 Download Files from SDS Web Site.
• **Decode Sabre Screen** - Decodes SDS message in current Sabre Screen.
• **About** - The submenu is used to bring up the About window that display the SDS test tool version and database update information.
• **View XML** - Turns XML viewing on or off.

### 2.3 Sub Windows

The SDS test tool has six sub windows that can be displayed at the same time. The following sections describe these sub windows.

#### 2.3.1 Sabre Display Window

The Sabre Display window is used to display the SABRE response and SDS formatted message string. Messages that exceed 62 KB will generate multiple Sabre Response screens. Changing of the title to include a number in the caption will indicate multiple screens. Successive screens can be accessed by double clicking the text area. This window should be kept open while the SDS test tool is running.

![Sabre Response Window](image.png)

**Figure 7. Sabre Response Window**
2.3.2 MDR Display Window

The MDR Display window is used to browse the MDR list in the MDR list view and look at the segment and element definitions of the selected MDR in the MDR detailed view. The MDR Detail list view will be displayed when the window is first brought up. When the SDS test tool is decoding a SDS formatted message, the MDR for the message will be displayed in the Detail List window. Clicking on the Show MDRs button will bring up the MDR list. The Retreive MDR from Host button will retrieve the select MDR from Sabre and add it to the database Data Base used to decode the message. The print MDR button will create a text file containing the MDR information. Right clicking on the Show button and selecting the desired sequence will select the sort sequence of the MDR List.

Figure 8. MDR Display Window in MDR List View

Figure 9. MDR Display Window in Detailed View

- The “Print MDR” button will place a copy of the MDR in a Microsoft Word document.
• The “Retreive MDR from Host” button will retrieve the selected MDR from Sabre and add to the database used to decode messages.
• MDR sort sequence can be changed by “right clicking” on the “Show” button and selecting the sort sequence desired from the dropdown window.

2.3.3 SDS Display Window

The SDS Display window is used to display the decoded SDS formatted message. The Descriptions are maintained in the MSAccess file downloaded from the sds.sabre.com web site.

![Figure 10. SDS Display Window](image)
2.3.4 Timer Functions Window

The Timer Functions window is used to display the various times for getting response from the SABRE host and decoding the SDS formatted message. It also displays the message length and the element count. Clicking on the Stop button sets the current wait time to zero.

![Figure 11. Timer Functions Window](image)

2.3.5 Hex Display Window

The Hex Display window is used to display the Hexadecimal value of the content in the clipboard or Sabre Response window. After clicking on the Clip Board button the content of the clipboard is displayed in the window with a hexadecimal value below each character. After clicking on the Sabre Response button the content of the Sabre Response window is displayed in the window with a hexadecimal value below each character. The string size of the content is displayed in the Size edit box.

![Figure 12. Hex Response Window](image)
2.3.6 XML Display Window

The XML Display window is used to show how Sabre data looks in XML format. There are two views which can be selected. The raw XML view has a counter which shows the total length of the message. The Dom view this counter displays the number of nodes in the XML message. Chg View alternates the XML and Dom view. Build Dom builds the Dom view from the XML message. Export Dom writes the Dom view to a file. Unicode is used to display the Unicode for Sabre Special characters.

![XML Response](image)

**Figure 13. XML Display Window**
2.4 Select SDS Directory

The first time you run the SDS test tool, you must select the SDS Directory submenu of the File menu (Figure 2. File Menu) to set up the SDS directory. The SDS test tool uses Gds.mdb as the MDR description database that is maintained by SDS Admin and published frequently with updated MDRs on the web site. To get the latest version of Gds.mdb file, you can download Mdrdata.exe zip file and extract Gds.mdb file to the SDS directory. You may change the SDS directory anytime in the Select Directory window. From the following Select Directory window, you can also specify the SDS web site.
2.5 Set up SABRE Communication

The SDS test tool uses the Common SABRE API (CCSAPI) as the communication API for connecting to the SABRE host. Currently there are three possible Services that provide Sabre connectivity; OSG, OFEP, and HSSP. You can select the SABRE Communication submenu of the File menu (Figure 2. File Menu) to bring up the SABRE Communication Setting window to choose different settings. From the following SABRE Communication Setting window, you can select the session for CCSAPI. CCSAPI settings are contained in the CSAPI.CFG file. Please refer to the CCSAPI Programmers Reference Manual for information on the setting up the CSAPI.CFG file.
2.6 Connection to SABRE

The SDS test tool connects to the SABRE host automatically when it runs. If the connection is successful, the button on the main window (Figure 1. Main Window) displays "Disconnect XXXXXXX". "XXXXXXX" will be the Session you chosen for CSAPI. If the connection failed, the button on the main window displays "Connect XXXXXXX". You should check if the CSAPI settings are correct and the CSAPI.cfg file is in the Systems directory. If the settings are correct and you still cannot connect to SABRE, you can try command "regsvr32 c:\cssds\COMuxCSAPI.dll" to register COMuxCSAPI.dll. "c:\cssds\ COMuxCSAPI.dll" should be changed to the full path to COMuxCSAPI.dll. you can retry the connection by select the Connect submenu of the Startup menu (Figure 3. Startup Menu). Select the Disconnect submenu of the Startup menu will disconnect from the SABRE host.
2.7 Sign in/out SABRE

After the successful connection to the SABRE host and the selection of the test system, you can sign into the SABRE host by selecting the Sign In submenu of the Startup menu (Figure 3. Startup Menu). The following SABRE Sign-in window is displayed for you to enter the SABRE sign in fields. Agent should enter his/her pseudo city code in the Suf edit field as shown in Figure 18. SABRE Sign-in Window for Agent. You can sign out the SABRE host by selecting the Sign Out submenu of the Startup menu. The current system connection will be displayed. This can be changed by activating the dropdown menu and selecting the desired system. Supplying the partition and password in the appropriate fields and selecting the Change Partition button can change partitions.

*(note: Not all Partitions and systems are available.)*

Figure 15. SABRE Sign-in Window

Figure 16. SABRE Sign-in Window for Agent
2.8 Send SABRE Command

Before sending a SABRE command, you must have already signed into the SABRE host.

The combo box in the main window (Figure 1. Main Window) is the place from which you can enter a SABRE command or select a previous SABRE command. There are two radio buttons on the main window. One is the Sds radio button and another is the Sabre radio button. When the Sds radio button is checked, it means the command will be sent as a SDS request command and the SABRE host will send back a SDS formatted message. When the Sabre radio button is checked, it means the command will be sent as a regular SABRE command and a SABRE screen scripting message will be sent back.

To send a SABRE command, check the Sabre radio button, type the SABRE command in the combo box and hit the Enter key. Then the SABRE response will be displayed in the Sabre Response window and the command is saved in the list of the combo box.

A gray data block is provided to the left of the connect command. By clicking this block a read is issued without sending to Sabre and displayed in the Sabre Response window.

2.9 Send SDS Command

Before sending a SABRE command, you must have already signed into the SABRE host.

The combo box in the main window (Figure 1. Main Window) is the place from which you can enter a SABRE command or select a previous SABRE command. There are two radio buttons on the main window. One is the Sds radio button and another is the Sabre radio button. When the Sds radio button is checked, it means the command will be sent as a SDS request command and the SABRE host will send back a SDS formatted message. When the Sabre radio button is checked, it means the command will be sent as a regular SABRE command and a SABRE screen scripting message will be sent back.

To send a SDS command, check the Sds radio button, type the regular SABRE command in the combo box (type in the 4-character subset Id in the Subset edit box if you are requesting a subset message. Otherwise the Subset edit box should be left blank.) and hit the Enter key. The SDS test tool will format the command internally into a SDS command and send it out. Then the SDS formatted message will be displayed in the Sabre Response window and the command is saved in the list of the combo box. The SDS test tool will decode the message, display the decoded information in the SDS Display window (Figure 10. SDS Display Window) and set the MDR for the message as the current selected MDR in the MDR Display window (Figure 9. MDR Display Window in Detailed View).
2.9.1 Send SDS Inbound Command

Before sending a SDS Inbound Command, you must have already signed into the SABRE host and the SDS radio button must be on.

In command combo box in the main window (Figure 1. Main Window), select the dropdown box and select “Inbound Commands”. This action changes the dropdown box from the “Previous Commands” to “Inbound Commands”. Once again select the dropdown box and select the Inbound Command desired.

The Inbound message window will be displayed showing the input segments and fields available and the MDR at the top. Highlighted segments are required segments and highlighted elements are required elements. Repeat factors for the segments and elements are shown in the Red circle in the figure 17.

To insert additional repeating segments double click on the segment to be repeated. An additional segment will be created for input. To insert an additional repeating elements double click on the element repeat factor circled in red.

Bridge check box flags to add the Bridge flag to the message. Action is the input space for the action code. This code is an optional field depending on the particular inbound message. Send command formats the inbound message and makes the call to Sabre. Cancel command closes the Inbound Screen. Format command formats the inbound message without sending to Sabre. Hide/Show command shows the text box containing the message to be sent.

The input mode can be switched back by selecting “Previous Commands.”
2.10 Retrieve MDR from SABRE Host

The SDS test tool uses the SDS C API to decode a SDS formatted message. The SDS C API uses the Ctree database to store MDR definition strings. The SDS test tool automatically downloads and saves a MDR definition string into the Ctree database files if the MDR is not found in the Ctree database. To retrieve a MDR manually, you should select the MDR in the MDR Display window (Figure 8. MDR Display Window in MDR List View) and click on the Retrieve MDR from Host button, the MDR will be retrieved from the SABRE host and overwrite the old one in the Ctree database.
2.11 Retrieve/Save SABRE Transaction

To retrieve a previous SABRE transaction, select the Retrieve Transactions submenu of SABRE Messages under the File menu (Figure 2. File Menu). From the Open File window you can open a SABRE transaction (.sab) file.

To save the current SABRE transaction, select the Save Transactions submenu of SABRE Messages under the File menu. From the Open File window you can enter a SABRE transaction (.sab) file name as the file to save the transaction.

2.12 Set up Printer Options

To set up the printer, select the Printer Setup submenu of Printer Options under the File menu (Figure 2. File Menu). The Printer window will be displayed for you to set up the printer.

To change the printer fonts, select the Printer Fonts submenu of Printer Options under the File menu. The Font window will be displayed for you to choose the font, style and size.

2.13 Set up Screen Options

The SDS test tool provides the functionality to set up screen colors and fonts according to your preference. Selecting the Change Screen Options of Screen Option submenu under the File menu (Figure 2. File Menu) will display the Screen Options window.

![Screen Options Window](image)

Figure 18. Screen Options Window
To set up colors for a window, check the Color radio button on the Screen Options window and check the radio button for the window you want to set up the color. Each window can have several colors to set up for the different parts of the window. Check the radio button in the right frame for the part that you want to change the color for. The standard Color window will be displayed for you to choose the color. After you finished setting up colors for a window, click on the Save Screen Options button to save the change you have made.

To set up fonts for a window, check the Font radio button on the Screen Options window and check the radio button for the window you want to set up fonts. Each window can have several fonts to set up for the different parts of the window. Check the radio button in the right frame for the part that you want to change the font. The standard Font window will be displayed for you to choose the font. After you finished setting up fonts for a window, click on the Save Screen Options button to save the change you have made.

After you are satisfied with your screen settings, you can select the Save Screen Options of the Screen Options submenu under the File menu to save the window settings. You can select the Set Screens Options to Default of the Screen Options submenu under the File menu to set the current window settings to be the default settings.

2.14 File Test

This functionality is used to test a bunch of SABRE commands from a text file and output all SABRE responses of those commands to a text file. Selecting the File Test submenu of the File menu will display the File In and Out window (Figure 19. File Test Window in Running Status View). The Sabre Input File edit box is used to enter the text file in which contains a list of SABRE commands. The Sabre Output Log edit box is used to enter the text file to save the SABRE response. You can browse existing files by clicking on the Browse buttons. Clicking on the Retain File Names button will save the current Sabre input and output file name as the default file names. If the Append Log check box is checked, the SABRE response will be appended to the existing Sabre output file. The Repeat field tell the number of times the file is to be executed. A blank in column one in the file will bypass the record and proceed with the next record. “Pause” will pause processing after each message is processed. “NOPAUSE” will stop the pause after each message. Input containing a x”86” (†)jn position one will be sent to the SDS processing routines. All others will be set to Sabre screen processing.
The File In and Out window has two views: one view is for editing the input file (Figure 20. File Test Window in Input File Editing View) and another view is for displaying the running status (Figure 19. File Test Window in Running Status View). To edit the Sabre input file, click on the Edit Input button to display the content of the input file in an edit box from which you can edit the input file. After you finish editing the input file, click on the Save button to save the input file. You can execute those commands in the input file by clicking on the Execute Input button. The running status will be displayed in the window. You must have successfully signed into the SABRE host before executing the input file.

![Figure 19. File Test Window in Running Status View](image-url)
2.15 **Print Output**

The SDS test tool can print out selected contents from the Sabre Response window, SDS Display window and MDR Display window. For example, highlight rows in the Elements grid in the MDR Display window and select the Print from Active Screen submenu of the Output menu (*Figure 4. Output Menu*), the Elements grid is printed out with selected rows.

2.16 **Export Output**

The content of the Sabre Response window can be exported to a text file and displayed in the Microsoft Word. Selecting the Sabre Response of Copy to Word submenu of the Output menu (*Figure 4. Output Menu*) to open a temporary file and follow the instruction to pop up the Microsoft Word with the temporary file opened.
The content of the SDS Display window can be exported to a text file and displayed in the Microsoft Word. Selecting the SDS Display of Copy to Word submenu of the Output menu to open a temporary file and follow the instruction to pop up the Microsoft Word with the temporary file opened.

The contents of the SDS Display window can simply be exported to a text file. Select the Export SDS Output submenu of the Output menu to open a file to save the SDS output.

2.17 Download Files from SDS Web Site

After correctly entered the SDS web site address in the Select Directory window (Figure 13. Select Directory Window), you can access the web site from the SDS test tool.

Since the MDR description database gds.mdb is updated frequently, you need to download the mdrdata.exe file to view the newest changes to MDRs. You can download the mdrdata.exe file through your web browser or you can select the Download Description Database submenu of the Help menu (Figure 6. Help Menu) to download it from the SDS test tool. But after download the database, you need to close the SDS test tool before you unzip the mdrdata.exe file.

If you want to get the latest version of the SDS test tool, you can download the sdsinstl.exe file through your web browser or you can select the Download Program Install submenu of the Help menu to download it from the SDS test tool. However, after downloading sdsinstl.exe, you need to close the SDS test tool before the installation. But after download sdsinstl.exe, you need to close the SDS test tool before you unzip the file.